You receive an error when attempting to upgrade to Adobe Acrobat Reader 2.0 for the Handheld PC

CESD-S-0112

Applies To:

  • HPC2000

Overview:

When attempting to upgrade Adobe Acrobat 2.0 for the Handheld PC from the 1.0 release, you receive the following error message:

Adobe Acrobat Reader for Pocket PC 1.0 is already installed. Please uninstall it before installing Adobe Acrobat Reader for Pocket PC 2.0

At this point the installer will terminate and you will be unable to install the Acrobat Reader 2.0 release.


More Info:

The error message is caused by an ambiguity between the Acrobat 1.0 installation registry settings and an automatic check made by the Acrobat 2.0 installer designed to check whether the 1.0 release has been successfully uninstalled.

The result of an error in the Acrobat Reader 1.0 uninstallation routine is that the 2.0 version installer believes that the original release has not been removed from your Handheld PC.


How-to Guide:

In order to install the Acrobat 2.0 redistributable on your Handheld PC you must first uninstall any previous versions of Acrobat that exist on your H/PC. If this alone does not resolve the error, you must edit the Windows CE system registry.

WARNING: If you use a Registry Editor incorrectly, you may cause serious problems that may require you to hard reset your Handheld PC back to its factory installed configuration. Edit your Windows CE registry at your own risk.
  1. Uninstall Adobe Acrobat 1.0 for the Handheld PC
  2. Open your devices Registry editor
    If you require a registry editor for your device see CESDS0082
  3. Navigate to:
    HKEY_LOCAL_MACHINE\Software\Apps\
  4. Delete the sub key:
    Acrobat
  5. Install the Adobe Acrobat 2.0 for Handheld PC binary redistributable from HPC:Factor

The Acrobat 2.0 installer will successfully install the program onto your Handheld PC.