x
This website is using cookies. We use cookies to ensure that we give you the best experience on our website. More info. That's Fine
HPC:Factor Logo 
 
Latest Forum Activity

White screen when booting my HP620LX

gregorymarshall Page Icon Posted 2021-06-14 10:54 PM
#
Avatar image of gregorymarshall
Subscribers
H/PC Newbie

Posts:
9
Location:
United States
Status:
Hello, I've had my HP620LX for quite some time and up to now it's helped me a lot as a writing hobbyist without having to use a phone. Today, however, when I got back to re-sync it to my Dell Optiplex GX250 (Windows XP), the screen was completely white and pushing buttons wouldn't do anything. not even the power button.
I tried:
- Pushing the reset button several times, which shows the logo but then gets stuck at the white screen.
- Pulled out the main battery and re-inserted it, which still went to the white screen after boot.

Is there something I can do to fix this problem?



(20210614_165321.jpg)



Attachments
----------------
Attachments 20210614_165321.jpg (1037KB - 0 downloads)
 Top of the page
ax0n Page Icon Posted 2021-06-15 2:43 PM
#
Avatar image of ax0n
H/PC Newbie

Posts:
20
Location:
United States
Status:
Is there a backup coin cell battery in there as well? I don't know the 620 model too well, but it's probably under a panel on the bottom of the unit. Try removing that as well when you remove the 620 from power and battery, too. The only time I've seen white screens on these units:

1) Memory is corrupted e.g. rebooting from Linux or BSD, or resetting after a really bad application crash. This usually results in a FAINT HP logo then a white screen. The fix for me has always been to ensure the backup battery is removed, the unit is unplugged, then remove the main battery for up to 30 seconds. This has usually resolved that issue.
2) Bad screen cable -- but in those cases, I never see anything on the screen, no logo or anything. Sometimes the cable itself is faulty, but usually it just needs to be removed and re-attached firmly from either the screen side or logic board side.
 Top of the page
gregorymarshall Page Icon Posted 2021-06-15 7:21 PM
#
Avatar image of gregorymarshall
Subscribers
H/PC Newbie

Posts:
9
Location:
United States
Status:
I followed your first point and I can judge that it's not the screen cable because I can see the logo and quite clearly.
After re-inserting the main battery with the backup cell removed, I saw the bios screen and logo, but then the screen went black.

I do have a PDF of the 620LX manual handy, and per its "Hard Reset" step, I'm currently waiting 3 minutes before re-inserting both batteries.

If you have any additional tips, don't hesitate to suggest them.
 Top of the page
gregorymarshall Page Icon Posted 2021-06-15 7:30 PM
#
Avatar image of gregorymarshall
Subscribers
H/PC Newbie

Posts:
9
Location:
United States
Status:
Scratch my previous reply. Following the manual's "Hard Reset" step seems to have helped.

- Left both batteries out for 4 minutes
- Reinserted both afterward
- Palmtop successfully booted after connecting power cable
- Now facing Windows CE reset screen.

I think the problem's resolved. thanks for your suggestion.
 Top of the page
hpc:factor« View previous thread · Windows CE 2.0 · View next thread »
Jump to forum:
Seconds to generate: 0.173 - Cached queries : 10 - Executed queries : 61
Server Time now is: Saturday, 24 July 2021 - 5:23