x
This website is using cookies. We use cookies to ensure that we give you the best experience on our website. More info. That's Fine
HPC:Factor Logo 
 
Latest Forum Activity

Image with network support

JohnGalt Page Icon Posted 2022-06-16 4:14 AM
#
Avatar image of JohnGalt
Subscribers
H/PC Newbie

Posts:
3
Location:
Brazil
Status:
I'm trying to use a legacy WindowsCE 5 application in a newer computer. I already got it running over emulation. It is running pretty well in terms of performance. The problem is the network.
If I understood right the x86 ready to use images should have the "Vitalised DEC 21140A" net card but for some reason it is not working. Or at least I'm unable to make it work,
I would like to ask for some help in this field. If there is someone that could make this image charging for the support, even better. I made some images with BSP but was a long time ago. Chances are that WindowsCE8 (aka 2013) maybe also works.
Plan B would be the case of installing another driver.
Plan C would be to use the serial port, just like it was used with modems in the good old days. The problem is to write a faster serial driver on the WindowsCE side (faster than 19,200 or something like this) and a virual serial on the host side.
 Top of the page
C:Amie Page Icon Posted 2022-06-17 7:26 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
16,830
Location:
United Kingdom
Status:
Why don't you get hold of the Platform Builder 5 trial and build it yourself? You won't get much of a response because it's an awful commitment for someone to basically remotely build you a custom CE image, test and debug it.
 Top of the page
JohnGalt Page Icon Posted 2022-06-18 7:14 PM
#
Avatar image of JohnGalt
Subscribers
H/PC Newbie

Posts:
3
Location:
Brazil
Status:
Thanks for your suggestion. Actually I already tried it with Platform Builder for CE6, built some images but I were unable to get a working screen.
 Top of the page
C:Amie Page Icon Posted 2022-06-18 9:51 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
16,830
Location:
United Kingdom
Status:
Tht suggests a BSP driver error. Do you have a BSP for your hardware, if not you'll have to start there?
 Top of the page
JohnGalt Page Icon Posted 2022-06-19 11:57 PM
#
Avatar image of JohnGalt
Subscribers
H/PC Newbie

Posts:
3
Location:
Brazil
Status:
Short question: Someone knows what is the graphic driver used on the HPCfactor ? (or it runs using some RDP-like kind of solution ?)

Long question:
I will run it over emulation. So I could configure the emulator in several ways, including standard x86 or Mainstone III Arm, for instance. Both solutions native of Platform Builder.
The HPCfactor image runs on the emulators Qemu or Virtualbox - but have the problem of the network and to write files.
I created some images using Build Platform of CE 6 and CE 8 (aka 2013) in a lot of alternate ways (like booting with loadcepc, probably the same technique used by HPCfactor image file and others bootloaders like XLDR Boot) - the images boot but I got a black screen when calling nk.bin in all the configurations I tried.
So I'm wondering what would be the graphic driver used on the image of HPCfactor (maybe std VGA ? Maybe a driver that is not supplied with Build Platform ?) or even if it uses some kind of graphic card. I noted that when I go to suspend I got a 'connected Window' which makes me wonder if it is not running some king of server like VNC or Remote Desktop.
 Top of the page
C:Amie Page Icon Posted 2022-06-20 8:01 AM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
16,830
Location:
United Kingdom
Status:
It is the generic VGA/VESA driver
 Top of the page
Jump to forum:
Seconds to generate: 0.078 - Cached queries : 64 - Executed queries : 8
Server Time now is: Thursday, 1 December 2022 - 5:51