x
This website is using cookies. We use cookies to ensure that we give you the best experience on our website. More info. That's Fine
HPC:Factor Logo 
 
Latest Forum Activity

NEC MobilePro 900 ROM Update Issue

1 2
phoenixfireva Page Icon Posted 2022-10-04 6:05 PM
#
Avatar image of phoenixfireva
Factorite (Junior)

Posts:
27
Location:
United States
Status:
Hi all. I am hoping someone might be able to assist me. I purchased an NEC MobilePro 900 with HPC2000 on it. I wanted to update to the Bootloader and Windows CE .net 4.2 ROM Image for the MobilePro 900 Series from here. I have a 96MB CF Card and followed the instructions to the letter.

The problem I get is when I double click the Update.exe in the CF Card the screen goes black for about .5 seconds and then goes white and nothing happens. I have left it in this state for at least an hour.

If I pull the battery and AC it hard resets and then successfully reboots into HPC2000 (so at least I did not brick it).

I have no idea what I am doing wrong.

Can someone help me please? I really want the advantages of the .Net 4.2 ROM and the updated BL to 4.10.

Thanks.
 Top of the page
Rich Hawley Page Icon Posted 2022-10-04 6:39 PM
#
Avatar image of Rich Hawley
Global Moderator
H/PC Guru

Posts:
7,188
Location:
USA
Status:
What is your current bootloader version?
 Top of the page
phoenixfireva Page Icon Posted 2022-10-04 6:47 PM
#
Avatar image of phoenixfireva
Factorite (Junior)

Posts:
27
Location:
United States
Status:
Rich,

Currently it show the below in NEC Firmware Information

NEC MobilePro 900
Firmware Version: P530 V6.0
Build Date: Oct 4, 2004
PIC Firmware ID: 4.19.7
Bootloader Version: <2.1

Then the copyright stuff.
 Top of the page
torch Page Icon Posted 2022-10-04 8:24 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,821
Location:
United States 
Status:
Did you run the modem update before doing the 4.2 update.
when I bought my 900 last month with Hpc2000. I updated the modem first then the 4.2 official rom

Edited by torch 2022-10-04 8:25 PM
 Top of the page
phoenixfireva Page Icon Posted 2022-10-04 9:10 PM
#
Avatar image of phoenixfireva
Factorite (Junior)

Posts:
27
Location:
United States
Status:
I did the modem update first. It was no issues. Then I restarted the MP and got the same problem. I am not very knowledgeable about these things but I suspect it has to do with the REALLY old BL present.

Torch, what BL Version was on yours before you updated?


Edited by phoenixfireva 2022-10-04 9:39 PM
 Top of the page
torch Page Icon Posted 2022-10-04 10:09 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,821
Location:
United States 
Status:
I don’t recall what boot loader version I was on before upgrading to 4.2. But. I had some thoughts:
1-Is your CF card formatted to the correct file system FaT16 and cluster size?
2-Is there a different CF card you can try?
3-were you removing and putting back in the coin backup battery in the correct steps of the guide ?



Edited by torch 2022-10-04 10:15 PM
 Top of the page
phoenixfireva Page Icon Posted 2022-10-04 10:42 PM
#
Avatar image of phoenixfireva
Factorite (Junior)

Posts:
27
Location:
United States
Status:
torch,

I have tried 3 different CF Cards. I formatted them using a third party tool since my machine is Win 10. I formatted them to FAT16 using the default cluster sizes.
The directions from HPC say to remove the Coin backup battery before starting. That is what I did.

Am I missing something? Did you use a guide other than the one provided on HPC download page for the ROM upgrade?

Thanks for helping.
 Top of the page
torch Page Icon Posted 2022-10-04 10:46 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,821
Location:
United States 
Status:
This is the guide I followed up exactly to the letter:

CE 4.2 ROM Image + Boot loader P530_42 2.02 + 4.10BL

Bootloader and Windows CE .net 4.2 ROM Image for the MobilePro 900 Series. Packaged by HPC:Factor Installation Instructions ========================= Prerequisites: - MobilePro 900/900C - MobilePro AC Adapter & Power Source - MobilePro Main Battery - CF Card >=64MB NOTE: Do not use this version of the flash update if your NEC's Bootloader is already version 4.10. 1. Format the CF card as FAT16 with default cluster sizes 2. Inflate the file download onto the CF card by double clicking hpcf_nec_p530_42-202.exe and pointing to the root of the CF card 3. Save all information you wish to keep on the MobilePro 4. Remove the coin cell battery 5. Ensure that the main battery is inserted and the device is connected to AC 6. It is suggested that users run the NEC Modem Firmware update for their device at this point 7. Insert the CF card into the MobilePro 8. Close any running applications 9. Browse to the CF card and double tap UPDATE.EXE 10. Follow any on screen instructions The update procedure can take between 5 and 15 minutes and should not under any circumstances be interrupted or experience a change in power state (e.g. disconnection from the AC supply). During the flash operation, the Bootloader and the Operating System will be updated.
 Top of the page
phoenixfireva Page Icon Posted 2022-10-04 10:51 PM
#
Avatar image of phoenixfireva
Factorite (Junior)

Posts:
27
Location:
United States
Status:
torch,

Exactly what I did. at least 3 times since I used 3 CF cards. When I double tap update.exe the screen goes black for about .5 seconds and then goes all white and nothing else happens. I waited an hour the last two times with no change.

It is very confusing because everything else seems to work. I updated the modem without issue and all other functions seem to work just fine.

Sigh...

Steve
 Top of the page
torch Page Icon Posted 2022-10-04 11:10 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,821
Location:
United States 
Status:
Ok. I have one more idea.
Can you try redownloading the rom update file. Delete the original one and start fresh ?
Maybe it was a corrupt download.

Also. Can you send me a picture of the root directory of what your CF card looks like if the first part doesn’t work?
 Top of the page
phoenixfireva Page Icon Posted 2022-10-04 11:37 PM
#
Avatar image of phoenixfireva
Factorite (Junior)

Posts:
27
Location:
United States
Status:
Ok. Here is a screen capture of the contents of the drive's root and the properties of the CF Card.



(Contents and Properties.PNG)



Attachments
----------------
Attachments Contents and Properties.PNG (87KB - 0 downloads)
 Top of the page
torch Page Icon Posted 2022-10-05 12:15 AM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,821
Location:
United States 
Status:
Thanks. Later tonight I’ll check my cf card. I don’t think I deleted the rom image
And you tried redownloading the file in case it was corrupted?
 Top of the page
phoenixfireva Page Icon Posted 2022-10-05 12:23 AM
#
Avatar image of phoenixfireva
Factorite (Junior)

Posts:
27
Location:
United States
Status:
Yes. That is a fresh download right after I got your last message.
 Top of the page
torch Page Icon Posted 2022-10-05 1:41 AM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,821
Location:
United States 
Status:
I’m sorry. I think I’m out of ideas. I’ll let you know if I think of anything else
 Top of the page
phoenixfireva Page Icon Posted 2022-10-05 2:02 AM
#
Avatar image of phoenixfireva
Factorite (Junior)

Posts:
27
Location:
United States
Status:
Thanks. Appreciate it.
 Top of the page
1 2
Jump to forum:
Seconds to generate: 0.218 - Cached queries : 72 - Executed queries : 10