x
This website is using cookies. We use cookies to ensure that we give you the best experience on our website. More info. That's Fine
HPC:Factor Logo 
 
Latest Forum Activity

System Hangs on first boot (720 Degrees)

1 2
mik01aj
mik01aj Page Icon Posted 2006-10-12 3:35 PM
#
Status:
Warning: unable to open an initial console.
I get something like this when I'm trying to boot familiar linux with opie (I took the image from http://www.lowlevel.cz/log/images/opie-image-jornada720-20050407154438-covex.rootfs.tar.bz2

I follow the howto from http://www.lowlevel.cz/log/pivot/entry.php?id=41

I unpacked the image with -xjvf and i still get the same error.

I also found something like this on http://www.handhelds.org/pipermail/jornada/12/1298.html:
Quote
"Warning: unable to open an initial console."

Ok, there really was no /dev/console, so I mknoded one with my normal PC.

... so what EXACTLY shall I do?

Thanks in advance for your help (and sorry for my English)
 Top of the page
Styx Page Icon Posted 2006-10-13 2:33 PM
#
Avatar image of Styx
H/PC Newbie

Posts:
1
Status:
Hi there!
I tried to use 720Degrees on my Jornada 720. I used to try NetBSD, but it just works proper on console and of course I want to use the touchscreen

I used this howto und did exactly what it describes: http://stevenwiki.homedns.org/720/#downloads

Trying kernel 2.6 never really worked. It stopped with a kernel panic saying that it is impossible to mount root. So I decided to try Kernel 2.4 which also failed with this line:

Kernel panic: No init found. Try passing init= option to kernel.

Some changes in the params.txt like init=/linuxrc keepinitrd did not work. Has someone an idea? Thanks for helping!
 Top of the page
mik01aj
mik01aj Page Icon Posted 2006-10-13 3:38 PM
#
Status:
OK, I solved my first problem, I just had to find out how to make device files in linux using mknod command.

Now, the boot goes further, and I can open a shell or try to load OPIE ("Loading Opie in 5 seconds... Press any key to interrupt" or something like this ). But the problem is that when I try to run OPIE, the screen turns black (without any cursor or anything, just black) and doesn't do anything. I pressed all the keys, and waited for about two minutes, but in vain The only thing I can do is turning the display on and off with the power button (and it doesn't even diplay the "Suspending!" messege).

Any ideas?
Thanks in advance
 Top of the page
sophisticatedleaf Page Icon Posted 2006-10-22 2:51 AM
#
Avatar image of sophisticatedleaf
H/PC Elder

Posts:
2,294
Location:
Sunny California
Status:
Styx - That init line is totally wrong. You are missing the initrd, go get it from Gernoth's site - I know the link is around on one of these threads.

mik01aj - There is something about how you are installing it that is wrong - I have gotten your problem before by installing it wrong. It looks like I will just make a temporary image file for everyone who cannot seem to get it to work, and troubleshoot from there.
 Top of the page
Khoja
Khoja Page Icon Posted 2006-11-02 11:57 PM
#
Status:
That's not very helpful. I have the same issue and the initrd-2.4.32.gz is definitely present and the path is correct in the params.txt file. Styx, or anyone else, if you have managed to resolve, please advise how.

Khoja
 Top of the page
sophisticatedleaf Page Icon Posted 2006-11-07 8:07 PM
#
Avatar image of sophisticatedleaf
H/PC Elder

Posts:
2,294
Location:
Sunny California
Status:
Well, I am not going to bother to read through this all again. Lets start from the top - many users, thanks to a flawed layout on the instructions page, have gotten the wrong base. Did you get the 2.6 etch one, or the 2.4 base that happens to be right underneath the 2.4 kernel. I would send you the image, but my pc is not cnnected right now.

The problem is, users with problems are not being clear about where the problem began, probably because they are not 720degrees developers. But without this, fixing these problems is like searching in the dark.
 Top of the page
pop
pop Page Icon Posted 2008-01-21 2:33 AM
#
Status:
happy_prad9@yahoo.com

  • system is hang


 Top of the page
1 2
Jump to forum:
Seconds to generate: 0.171 - Cached queries : 60 - Executed queries : 9