This website is using cookies. We use cookies to ensure that we give you the best experience on our website. More info. That's Fine
HPC:Factor Logo 
Latest Forum Activity

Multiple device types and ActiveSync

takwu Page Icon Posted 2004-10-13 2:38 PM
Avatar image of takwu
H/PC Elder

BC, Canada
Hi, I have been a long time PPC user. I recently got an H/PC, the Jornada 728. I found a very irritating problem with ActiveSync

I'm going to use MiniStumbler (www.netstumbler.com) as an example. I installed it when my H/PC is connected. It installed as if everything was ok; but when I ran the program, it crashed (illegal operation). At first I thought it was the program's fault, but after reading so many stories with success, I had doubt about my setup.

So I uninstalled it from the device (Remove Program Control Panel). Then on my pc I went to the ActiveSync folder and find MiniStumbler. It has 6 cab files, each for a diff version: HPC2000 arm and mips, PPC arm mips sh3, and PPC2002 arm. So I just copied the correct cab file to the device and installed. And the program worked just fine.

To find what was wrong the first time, I uninstalled MiniStumbler from the device again and tried the other cab files that don't match my Jornada. I found that the MIPS cab files won't work because it detects the difference; but all the ARM versions installed, and both the PPC and PPC2002 versions would crash just like it did the first time.

So I'm saying that the installation via ActiveSync screwed up and gave my device the wrong OS version of the program. I don't know if ActiveSync is to blame or the installer. It seems other people who have only one device do not have this problem. And I think some other programs I tried in the past, that also crashed on the Jornada, might just be the wrong version

Anyone else got screwed by this problem before?
 Top of the page
C:Amie Page Icon Posted 2004-10-13 6:41 PM
Avatar image of C:Amie
H/PC Oracle

United Kingdom
Chances are that the installer script used to make the install cab is programmed incorrectly.
Specifying the 3.0 version but not the correct platform.
So it will allow install under HPC2000 without complaint.

It's easy to do, the install scripts aren't all that fun to be making.

It's when they get the file copy permissions wrong that life really gets bad.
 Top of the page
Jump to forum:
Seconds to generate: 0.109 - Cached queries : 60 - Executed queries : 8