x
This website is using cookies. We use cookies to ensure that we give you the best experience on our website. More info. That's Fine
HPC:Factor Logo 
 
Latest Forum Activity

J720 Battery Woes Continue

KBoyKool Page Icon Posted 2010-02-23 6:14 PM
#
Avatar image of KBoyKool
H/PC Philosopher

Posts:
406
Location:
Indiana, USA
Status:
Following my CRASH I have continued to have problems. I immediately replaced my backup battery, but ever since the crash I will randomly have a warning screen popup that my backup battery is expired and I will lose information. However, when I open HP Settings and check the Power Properties, my Backup Battery is always "Good". Any ideas?
 Top of the page
Rich Hawley Page Icon Posted 2010-02-23 6:25 PM
#
Avatar image of Rich Hawley
Global Moderator
H/PC Guru

Posts:
7,188
Location:
USA
Status:
Probably just making intermittent connection with the contacts. Make sure they securely press against the battery. Might be a loose connection from the backup battery to the motherboards...
 Top of the page
CE Geek Page Icon Posted 2010-02-24 12:31 AM
#
Avatar image of CE Geek
Global Moderator
H/PC Oracle

Posts:
12,667
Location:
Southern California
Status:
Rich is right; that's a common problem with the J72x. To tighten the connection, remove the backup battery and try to bend the connection plate downward a bit, and then put the backup battery back in.
 Top of the page
MrSB Page Icon Posted 2010-02-24 1:52 AM
#
Avatar image of MrSB
Factorite (Elite)

Posts:
114
Location:
Hong Kong SAR
Status:
Perhaps you can clean the contacts with a little alcohol. A bit masking tape may also help fix the loose contacts.
This kind of battery issue also has occurred to me. It happened after several hard-resets/cold boots to recover from a terrible system crash. I put in anew backup battery but the machine still said it was depleted. The problem was gone after I reinserted the backup battery, gave the main battery a full charge and did a couple soft-resets. I didn't know which did the magic, though.
 Top of the page
KBoyKool Page Icon Posted 2010-02-24 6:05 PM
#
Avatar image of KBoyKool
H/PC Philosopher

Posts:
406
Location:
Indiana, USA
Status:
Before I received any responses, here, I did flex the contacts gently and checked for signs of corrosion or wear. The contacts still bear a mirror finish at all points, but I did rub them a bit for good measure and wiped them so that no skin oil would obstruct the flow of electrons. We will see if this cures the problem. Thanks, everyone. I'll keep you posted.
 Top of the page
Jump to forum:
Seconds to generate: 0.172 - Cached queries : 61 - Executed queries : 10