x
This website is using cookies. We use cookies to ensure that we give you the best experience on our website. More info. That's Fine
HPC:Factor Logo 
 
Latest Forum Activity

3Com 3C589x Driver for HPC2000

Moderators: CE Geek, Rich Hawley

Jump to page : 1 2 3
Now viewing page 1 [15 messages per page]

C:Amie Page Icon Posted 2004-09-19 2:01 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
15,378
Location:
United Kingdom
Status:
The HPC:Factor distributed 3Com 589 series Driver is a popular topic of support.

Please use this forum to discuss drivers and driver problems for the 3C589 series PCMCIA Ethernet Adapter under HPC2000.

More Info: CESD-H-0017

All potential 3C589x users - Please be aware that as of 2005 we recommend only the 3C589C model. Reports of success with the 3C589D have been sketchy.
 Top of the page
fish
fish Page Icon Posted 2004-11-15 7:26 AM
#
Status:
Yesterday I tried to install this driver on my MP-C33 (JVC) and at first it seems, it would all be ok; entering IP-Adress and so on, but then no tray-icon occurred and no connection was possible (only ping to its own ip ;-)).

Is there any debugging possibility or another beta-version of the dll for the NEC4122-processor?

Thx for any hints

fish
 Top of the page
C:Amie Page Icon Posted 2004-11-15 8:47 AM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
15,378
Location:
United Kingdom
Status:
The tray icon doesn't appear under HPC2000.

With all 3Com 589 series adapters the NIC has to be set in EPROM on the moded it is using, the things cannot auto select like on the PC.
The tools for that are in the 3Com redist in their downloads area.

I was sent the bits by a user, they are based around a 3Com beta driver, and they suspended work on it completly. All modifications made to get it to work under HPC2000 are registry and settings based.
The only way to fix it would be to decompile it (disclaimer: I'm not suggesting anyone decompile it as that would be illegal. It's a matter of fact statement).

/sob story/
Secondly, when I was actively working on trying to improve the driver for people, only 3 people of roughly 300 who downloaded it while it was in beta bothered to let me know the results they were seeing. The 3 reported it was OK.

The people who couldn't be bothered to send in their experiences only contacted me after I released it to moan and grip about things not working. After which one has no incentive to even humour them.
I made a news post, stating my position - as above - and now have no wish to continue.

\sob story\

Any way, jear jerkers aside. It's worth investigating the state of the EPROM, reset it to default values and set the transfer mode manually. Don't enable full duplex either.
 Top of the page
fish
fish Page Icon Posted 2004-12-08 9:28 PM
#
Status:
I did so - but no success, all the card settings were defaults - nothing to do...
I tried much other things, the best (for laughing!) was my approach, to contact 3Com - almost an adventure!
First I ransacked their "KB" - not much to find, so i interchanged some messages with them, not much more; but they suggested to register on support. So i thought - why not?
I had to create an account, and after transmission of a lot of personnel stuff and technical messages they kindly clarified that my card is too old and out of standard support and if I would buy a new(!!) support contract for my 9 years old little PCMCIA-card, I could get help; maybe...

The core of my question was: the original driver software of 3C589 requires after a few preparing installation steps the original WindowsCE CD-ROM - how can I get it? The system of my MP-C33 dwells in a ROM, therefore JVC did not supply any System-CD.

Now I´m looking for tricks to simulate the presence of a CE-CD to test this driver package. Maybe it is a poor vagary, but there´s so few time...

Cheers - Andreas
 Top of the page
C:Amie Page Icon Posted 2004-12-09 7:13 AM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
15,378
Location:
United Kingdom
Status:
As clearly stated on the docs the original driver is for Windows CE 2.00 ONLY.
It is available for download without the need for the CD from this site.
As is an ISO of the CD.

Again, it's for CE2.00 Only not HPC2000.
 Top of the page
jornada720 Page Icon Posted 2006-03-27 4:41 PM
#
Avatar image of jornada720
Factorite (Elite)

Posts:
134
Location:
United States
Status:
Is the 3CCE589EC card compatible with the Jornada 720
 Top of the page
C:Amie Page Icon Posted 2006-03-27 5:21 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
15,378
Location:
United Kingdom
Status:
Unknown I'm afraid.
 Top of the page
nutsch Page Icon Posted 2006-04-22 1:19 PM
#
Avatar image of nutsch
H/PC Newbie

Posts:
6
Location:
Oregon
Status:
yeah I have the 3c589d and it just locks up once I type in the driver name. It's fine once I remove the card but tried it about 1000 times with no sucess. So anyone with a solution let me know. Otherwise I'll be trying to make one of my other 16 bit cards work(don't look to have support either...)

Thanks,
Travis
 Top of the page
C:Amie Page Icon Posted 2006-05-14 9:58 AM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
15,378
Location:
United Kingdom
Status:
I'm still unable to reproduce a pattern in 589 series behaviour. I've tried this before and got nowhere, but I'll try it again because CmoneX has asked me to.

In the link at the bottom of this post is an Excel file. In it I have placed adapter information gained from the back plat of the 589 cards I've tested and information from the 3Com diagnostic utility that you can download in CESDH0022.

Anyone who would like to get to the bottom of the 589 problem please have a look at the XLS file so you know what information you need to gather, and please post it as a reply in the applicable Sticky thread in the CE2, H/PC Pro or HPC2000 support sections. I will then correlate the data into the spread sheet and update it.

For anyone who knows of such thing Please do provide the MAC address, it could correlate into a pattern.

Download: No longer available
 Top of the page
cmonex Page Icon Posted 2006-05-14 11:14 AM
#
Avatar image of cmonex
H/PC Oracle

Posts:
16,175
Location:
Budapest, Hungary
Status:
wow thanks for this file! i'll check it right now! very interested


edit:
my cards:
(both etherlink III)

1) 3C589D
16-0037-000
REV: A

EA (ethernet address): 0060978D1E74

2) 3C589D-TP

16-0108-000
REV: B

EA: 0060088D4DB9

can't get more info right now (but i will get it within a few days, when i get that laptop with the floppy )


cards tested & didn't work: hpc2000 MIPS, ARM (J720, NEC900)... and ce.net 4.2 (nec 900c).

tested & worked: J680 (hpc pro SH3)
 Top of the page
C:Amie Page Icon Posted 2006-05-14 12:32 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
15,378
Location:
United Kingdom
Status:
Interesting, based upon both of your PN's you have different revisions to my four, same versions though.

I have tried forcing the resource settings onto different lines for the D, it makes no difference. This is categorically not a system resource problem. Resource realted changes in behavious must be down to the driver requiring a registry value to obtain addressing and control register access.

Just off to reset the EPROM to defaults.
 Top of the page
cmonex Page Icon Posted 2006-05-14 12:42 PM
#
Avatar image of cmonex
H/PC Oracle

Posts:
16,175
Location:
Budapest, Hungary
Status:
Quote
C:Amie - 2006-05-14 6:32 PM
I have tried forcing the resource settings onto different lines for the D, it makes no difference. This is categorically not a system resource problem. Resource realted changes in behavious must be down to the driver requiring a registry value to obtain addressing and control register access.


sorry i didn't understand this part what resource settings were you talking about here?


Quote
Just off to reset the EPROM to defaults.


curious to see the results. too bad i don't have such a laptop here (until next week)
 Top of the page
C:Amie Page Icon Posted 2006-05-14 12:49 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
15,378
Location:
United Kingdom
Status:
Everything we've spent most of the afternoon discussing over Pm. The Interrupt and io "effect".

Currently the EPROM reset doesn't seem to be having any affect what so ever. It's still worth doing once though, to clear its past life away.
 Top of the page
mbj720 Page Icon Posted 2006-09-28 2:36 PM
#
Avatar image of mbj720
H/PC Newbie

Posts:
17
Location:
United States
Status:
3Com Megahertz 10 Mbps LAN PC Card Model 3CCE589ET works fine on my Jornada 720, with the known bug #1 mentioned in the CESD-H-0017 (using the Beta Driver provided on the web page).

EA 00105AD217FC
PN 16-0180-000 REV:A
 Top of the page
octi
octi Page Icon Posted 2007-02-23 2:02 PM
#
Status:
i receantly bought a jornada 720 and i can't instal the 3com megahertz 3ccfe574bt ehernet card.when i plug in the card an error apperease "unidentified pccard adapter" . i tried to instal de beta driver but it doesn't work.can you help me please
 Top of the page
hpc:factor« View previous thread · Handheld PC 2000 · View next thread »

Jump to page : 1 2 3
Now viewing page 1 [15 messages per page]

Jump to forum:
Seconds to generate: 0.093 - Cached queries : 15 - Executed queries : 63
Server Time now is: Monday, 26 October 2020 - 19:18