x
This website is using cookies. We use cookies to ensure that we give you the best experience on our website. More info. That's Fine
HPC:Factor Logo 
 
Latest Forum Activity

Agere Orinoco Gold Firmware Updates

1 2
torch Page Icon Posted 2022-09-29 8:01 AM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,721
Location:
United States 
Status:
I can’t find a good place that I can locate information but I was wondering about the firmware updates for the Agere Orinoco Gold. I was particularly interested if I could get WPA working on it.

1-If I update the firmware, will it stop working with the original CE2.0 version of the driver?
2-what is the latest Windows CE 3.0-4.x compatible firmware (it’s not really a big deal if I can no longer connect under CE2.0)
2a-and are these firmware updates able to be applied in CE directly?
3-Are firmware updates persistent or do they revert upon power loss?

Edited by torch 2022-09-29 8:38 AM
 Top of the page
stingraze Page Icon Posted 2022-09-30 6:22 AM
#
Avatar image of stingraze
Subscribers
H/PC Vanguard

Posts:
3,678
Location:
Japan
Status:
1) It might, but you've got to try it out and see...
2) Not sure, I will search and update here if I find it.
2a) I believe there is some sort of flash utility used from a normal Windows OS for that.
3) Usually, firmwares are persistent. There was a thread on one Linux forum about downgrading firmware.
https://www.linuxquestions.org/questions/linux-newbie-8/how-to-downg...
 Top of the page
C:Amie Page Icon Posted 2022-09-30 7:19 AM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,979
Location:
United Kingdom
Status:
If you find them, we can create a support page for them.
 Top of the page
torch Page Icon Posted 2022-09-30 9:29 AM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,721
Location:
United States 
Status:
Thank you all! I found some information here

https://proxim.force.com/s/article/1082

It looks like firmware updates require Windows Desktop.
But, I remember flashing my old Orinoco Silver into a Gold card in Windows CE on my MP790 about eleven years ago. So I think perhaps some sort of flashing is available but I can’t remember or find how I did it.

That said, for the price of new hardware to firmware update it, I’m really just better off using my other Wifi card. It was more my OCD in being firmware up to date lol
 Top of the page
C:Amie Page Icon Posted 2022-09-30 9:51 AM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,979
Location:
United Kingdom
Status:
To answer your question, firmware should always be backwards compatible, though feature issues with old drivers can arise.
 Top of the page
torch Page Icon Posted 2023-11-08 4:58 AM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,721
Location:
United States 
Status:
So here’s an update :
I had @thenzero upgrade my Orinoco to the newest firmware and here’s what I figured out

For open wireless networks
Windows CE 2.0, 3.0, and 4.2 all work

For WEP wireless networks
Only Windows CE 4.2 works
CE2.0 and 3.0 do not.

Unfortunately I don’t have an exact before and after testing routine but I was able to switch between the Orinoco and Cisco Aironet 350 on Windows CE 3.0. The aironet worked on WEP but the Orinoco no longer does.

So long story short, I don’t recommend the firmware upgrades lol.


There were some old school Mac users who had non functional cards after upgrading the firmware. That should have been my clue.
 Top of the page
C:Amie Page Icon Posted 2023-11-08 9:09 AM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,979
Location:
United Kingdom
Status:
For the WEP key, are you entering the passphrase or the HEX key? A good number of these CE utility apps make a complete hash (pun intended) of passphrase based WEP keys.
 Top of the page
torch Page Icon Posted 2023-11-08 2:41 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,721
Location:
United States 
Status:
I’m pretty sure I’m doing it right because side by side I was trying the Cisco Aironet at same time and it worked
 Top of the page
C:Amie Page Icon Posted 2023-11-08 3:11 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,979
Location:
United Kingdom
Status:
HEX or passphrase?
 Top of the page
torch Page Icon Posted 2023-11-08 3:16 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,721
Location:
United States 
Status:
I'll retest both and let you know.
Can I do this? I made a stupid simple WEP 40 bit key

hty&V
^is ASCII

6874792656
is HEX

Does CE work okay (including CE2.0) with & symbols in the HEX, or should I regenerate and test with something with numeric/letters only?
 Top of the page
C:Amie Page Icon Posted 2023-11-08 3:40 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,979
Location:
United Kingdom
Status:
As long as they are ASCII symbols, it shouldn't matter, unicode, no.
 Top of the page
torch Page Icon Posted 2023-11-21 11:10 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,721
Location:
United States 
Status:
On my 790, I used the Cisco Aironet first and it worked immediately.
Then I switched to the Orinoco and it does connect but I keep getting “a connection with the server could not be established” in internet explorer.
The Cisco came up immediately

Edit I am thinking the last firmware isn’t compatible with Windows CE 3.0 or lower per this thread
https://www.hpcfactor.com/forums/forums/thread-view.asp?tid=10949&st...

This user had the same firmware as me and same issues

Edited by torch 2023-11-22 5:04 AM
 Top of the page
C:Amie Page Icon Posted 2023-11-22 9:13 AM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,979
Location:
United Kingdom
Status:
Are you getting an IP Address and DNS servers in vxUtil?
 Top of the page
CE Geek Page Icon Posted 2023-11-23 5:06 AM
#
Avatar image of CE Geek
Global Moderator
H/PC Oracle

Posts:
12,668
Location:
Southern California
Status:
Just a caveat: the Agere reference driver is WLAGS46.DLL, so entering WLLUC46 as the driver name (as per the linked thread) won't work unless you specifically install the older Lucent version on the device. Don't know if that could be the problem.
 Top of the page
torch Page Icon Posted 2023-11-24 2:27 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,721
Location:
United States 
Status:
Thank you all!
I have some updates.

I got the Orinoco Gold working on CE3.0 with the MobilePro 790. I didn’t have the right WEP key entered but the driver doesn’t actually tell you it’s wrong and just “connects”

So it does work there.

I couldn’t get the experimental version 8 Agere reference driver working on the 790 though.
The experimental driver does work on the 900 though ! (I couldn’t get WPA working though. Probably need AEGIS for that)


Now I just need to test the card with CE 2.0 but it looks like the CE2.0 drivers don’t support 128bit WEP. Only 40bit. (It didn’t like my key and gave an error message about it )

Am I missing something ? Or does it not support 128bit because 2.0 is so ancient?

Also is there a change log or any info on the v8 experimental agere reference drivers ? I just wanted to learn more
 Top of the page
1 2
Jump to forum:
Seconds to generate: 0.187 - Cached queries : 73 - Executed queries : 8