x
This website is using cookies. We use cookies to ensure that we give you the best experience on our website. More info. That's Fine
HPC:Factor Logo 
 
Latest Forum Activity

PVB Visual Basic Runtime MobilePro 900

1 2 3 4
CE Geek Page Icon Posted 2023-01-22 7:14 PM
#
Avatar image of CE Geek
Global Moderator
H/PC Oracle

Posts:
12,655
Location:
Southern California
Status:
Quote
I dunk for bananas - 2023-01-21 8:04 AM

@torch, I tried what you suggested in the x86 thread, but the PoQuickPro cab doesn't want to install on my device, so I had to extract the files from it manually, there don't seem to be any registry entries created by it. When I install the runtime afterwards and try to run PoQuickPro.vb, it tells me "The control picSplash {...} could not be created."


That error message usually means that MSCEPicture.dll isn't installed or isn't properly registered in HKEY_CLASSES_ROOT. If this file is present, try registering it manually with regsvrce.exe or RegSvr2.exe.
 Top of the page
I dunk for bananas Page Icon Posted 2023-01-22 7:47 PM
#
Avatar image of I dunk for bananas
H/PC Elite

Posts:
670
Location:
Europe
Status:
Quote
CE Geek - 2023-01-22 7:14 PM

Quote
I dunk for bananas - 2023-01-21 8:04 AM

@torch, I tried what you suggested in the x86 thread, but the PoQuickPro cab doesn't want to install on my device, so I had to extract the files from it manually, there don't seem to be any registry entries created by it. When I install the runtime afterwards and try to run PoQuickPro.vb, it tells me "The control picSplash {...} could not be created."


That error message usually means that MSCEPicture.dll isn't installed or isn't properly registered in HKEY_CLASSES_ROOT. If this file is present, try registering it manually with regsvrce.exe or RegSvr2.exe.


Thank you! It launches now, but it now crashes with "The control File1 {...} could not be created"
 Top of the page
I dunk for bananas Page Icon Posted 2023-01-22 7:59 PM
#
Avatar image of I dunk for bananas
H/PC Elite

Posts:
670
Location:
Europe
Status:
Tried registering all of the DLLs and now I'm getting "An error was encountered while running this program: ADO could not find the object in the collection..."

edit: this also crashed my system

Edited by I dunk for bananas 2023-01-22 8:04 PM
 Top of the page
torch Page Icon Posted 2023-01-23 3:58 AM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,554
Location:
United States 
Status:
Quote
C:Amie - 2022-11-08 7:07 AM

Quote
torch - 2022-10-12 5:11 PM

I tried installing the CE2.0 on my MobilePro 790 (without replacing the .dll files) but it hung at the "Creating Registry" part so I soft reset it. tried going into \Windows and trying the pvbload prog but it just hangs.


Coming back to this as I am conscious that we need to work out which dll registration is hanging as all of those cab's will be doing it.

Attached are the HPC2000 MIPS dll's in individual cab's. Could you please let me know which cause the problem in creating registry and which do not. Thanks

All of these work successfully on MobilePro 790 (clean install). No registry hanging

I also figured out that Citgo's programs, if I overwrite the dlls, it tries to install the CE2.11 versions-thus that's why I have issues on CE 3.0. But if I just install the program skipping dll overwrite, the programs of course work.

But, I'm confused, C:Amie/CE Geek.
What do I exactly need to do to test with the individual cabs? I'm confused what is wanted for me to do with the registry too...

I was having issues installing the CE2.0 VB runtime (maybe I didn't make this clear before) on the 790 (that's what was hanging the registry if I recall correctly), because I thought we were testing getting VB1.0 on HPC2000.
Then you made those indiv. cabs so we could isolate the problem (because I thought you somehow made a souped-up mega runtime combo for VB1.0/VB2.0 for HPC2000 mips)

I mean, I'm happy to test whatever you both want me to test. I was just confused on what I was testing. So I'll need a little more direction on that..

Edited by torch 2023-01-23 3:59 AM
 Top of the page
CE Geek Page Icon Posted 2023-01-23 6:55 AM
#
Avatar image of CE Geek
Global Moderator
H/PC Oracle

Posts:
12,655
Location:
Southern California
Status:
Keep in mind that some H/PC Pro and H/PC 2000 devices have the eVB runtimes in ROM, so you won't be able to install the PVB runtimes for CE 2.0 on those successfully.

I dunk for bananas, are the ADOCE files also installed (adoce31.dll, adocedb30.dll, adocedb31.dll, adoceoledb31.dll, adosync.dll, adosyncstub.dll, and adoxce.dll)?
 Top of the page
C:Amie Page Icon Posted 2023-01-23 10:06 AM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,931
Location:
United Kingdom
Status:
Quote
torch - 2023-01-22 4:41 PM

Ok. I have an idea and let me now what you think.
Your HPC2000 individual cabs:
I’ll :
Install each one individually and separately , and checking that .vb programs still load, hard reset, rinse repeat.
Then we can figure out which cab is problematic ?
The problematic CAB(s) should be immediately identifiable because the installer will fail
 Top of the page
C:Amie Page Icon Posted 2023-01-23 12:13 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,931
Location:
United Kingdom
Status:
Quote
torch - 2023-01-23 3:58 AM

Quote
C:Amie - 2022-11-08 7:07 AM

Quote
torch - 2022-10-12 5:11 PM

I tried installing the CE2.0 on my MobilePro 790 (without replacing the .dll files) but it hung at the "Creating Registry" part so I soft reset it. tried going into \Windows and trying the pvbload prog but it just hangs.


Coming back to this as I am conscious that we need to work out which dll registration is hanging as all of those cab's will be doing it.

Attached are the HPC2000 MIPS dll's in individual cab's. Could you please let me know which cause the problem in creating registry and which do not. Thanks

All of these work successfully on MobilePro 790 (clean install). No registry hanging

I also figured out that Citgo's programs, if I overwrite the dlls, it tries to install the CE2.11 versions-thus that's why I have issues on CE 3.0. But if I just install the program skipping dll overwrite, the programs of course work.

But, I'm confused, C:Amie/CE Geek.
What do I exactly need to do to test with the individual cabs? I'm confused what is wanted for me to do with the registry too...

I was having issues installing the CE2.0 VB runtime (maybe I didn't make this clear before) on the 790 (that's what was hanging the registry if I recall correctly), because I thought we were testing getting VB1.0 on HPC2000.
Then you made those indiv. cabs so we could isolate the problem (because I thought you somehow made a souped-up mega runtime combo for VB1.0/VB2.0 for HPC2000 mips)

I mean, I'm happy to test whatever you both want me to test. I was just confused on what I was testing. So I'll need a little more direction on that..


Okay, so the regsrv issue isn't with the CE 3 dll's it's coming from trying to overwrite the 3.00 ones with 2.00 or 2.11 ones. We're definitely going to have to re-write installers to solve this one

The individual CAB's were to test if it was a specific one of the DLL's causing the regsrv error and messing up the installation. Based on your initial comments on my combined test CAB not working due to the installer refusing to allow you to progress the install after registration failed. We need to work out clearly what the dependency chain is and exactly what is causing the problem. We've eliminated the 3.00 DLL's.

There isn't a misunderstanding. I am trying to solve the mess of ALL VB runtime problems and end-user confusion. Not just PVB.


CEVB 2.0
I think that this will represent a full fix for .VB (eVB 3.0 CEVB 2.0) files on CE 2.11 and 3.0, including x86 on CE 4/5/6:
Full Runtime: https://www.hpcfactor.com/scl/1982/Microsoft_Corporation/Visual_Basi...
Core Runtime: https://www.hpcfactor.com/scl/1983/Microsoft_Corporation/Visual_Basi...

I discovered in looking at the PE headers that the arm720 versions of the DLL's are actually Thumb, so I have changed that (naughty Microsoft)

If someone with 2.11/3/4/5/6 devices can confirm that they install and allow .VB's to work. Please let me know.


CEVB 1.0
This is for .PVB files ONLY. Having had a look at the DLL file set and the way it is wired. I think we've got a few different issues
1. I don't have any x86 file set for this. Are you saying that you do, or are your requests to get x86 working just for CEVB 2.0?
2. We need to register .PVB without upsetting .VB
3. Microsoft in their infinite wisdom used the same registration server ID's for CEVB 20 as they did for CEVB 1.0. This means that regsrv for both sets of DLL's are trying to write the exact same data to the exact same place in the registry. This is why everyone's devices are corrupting when they encounter .PVB or install .VB after they install .PVB on a non-runtimed device. so the question is: is the CEVB 2.0 control backwards compatible or are they incompatible and thus Microsoft's laziness has damned this exercise to be either one or the other and not both.
 Top of the page
C:Amie Page Icon Posted 2023-01-23 12:28 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,931
Location:
United Kingdom
Status:
Okay. This is for CE 2.11+ on MIPS

1) On a clean device
2) Install the VBCE 2.0 Full if the device doesn't have it already installed (yes 2.0)
3) Install the attached
4) Let me know if .PVB is a registered file type in the registry
5) See if a .PVB will load at all

This is attempting to force the CEVB 1.0's .PVB loader to use CEVB 2.0's control DLL's, so I wouldn't hold your breath.
 Top of the page
torch Page Icon Posted 2023-01-23 4:48 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,554
Location:
United States 
Status:
The CEVB2.0 runtime full installs correctly overwriting ROM dlls on my MobilePro 790, but for some reason, the installer thinks it's incompatible at the outset, I have to click yes to override but everything works correctly.

The PVBtest.ce211 says not valid CE Services file when I try to load that
 Top of the page
C:Amie Page Icon Posted 2023-01-23 5:03 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,931
Location:
United Kingdom
Status:
hummm, I wonder if HPC2000 is qualified as JUPITER as well as 2.11 in the CAB installer.
 Top of the page
C:Amie Page Icon Posted 2023-01-23 5:07 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,931
Location:
United Kingdom
Status:
Please pull VBCE-2.Full.HPC2000.mips.cab again and see if you get the same incompatibility error.

PVBtest.ce211 is even odder. I've regenerated it again here, attached.
 Top of the page
torch Page Icon Posted 2023-01-23 5:37 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,554
Location:
United States 
Status:
Quote
C:Amie - 2023-01-23 10:07 AM

Please pull VBCE-2.Full.HPC2000.mips.cab again and see if you get the same incompatibility error.

PVBtest.ce211 is even odder. I've regenerated it again here, attached.

VBCE-2.Full.HPC2000.mips.cab ^ no longer generates incompatible error - works correctly now.

C:Amie's PVBtest regeneration installs, but hangs at "setting registry entries"
 Top of the page
C:Amie Page Icon Posted 2023-01-23 5:53 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,931
Location:
United Kingdom
Status:
Ah, that answers that then. I learned something. Microsoft never updated the documentation for cab creation and HPC2000. I will have to regenerate all of the CE3 Cabs.

Curse, that means it might be sharing a required registration with the v2 runtime. That could be a terminal problem.

I've turned off for the day now though, so it'll have to wait until tomorrow, if I get the chance.
 Top of the page
torch Page Icon Posted 2023-01-23 5:58 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,554
Location:
United States 
Status:
Quote
C:Amie - 2023-01-23 10:53 AM

Ah, that answers that then. I learned something. Microsoft never updated the documentation for cab creation and HPC2000. I will have to regenerate all of the CE3 Cabs.

Curse, that means it might be sharing a required registration with the v2 runtime. That could be a terminal problem.

I've turned off for the day now though, so it'll have to wait until tomorrow, if I get the chance.

I don't understand why you're going to sleep so early, seeing as it's 10:55AM right now...

Quote
C:Amie - 2023-01-23 5:13 AM
1. I don't have any x86 file set for this. Are you saying that you do, or are your requests to get x86 working just for CEVB 2.0?

I don't have the x86 set for CEVB1.0, this was in regards to CEVB2.0.

In either event, thank you for all of your hard work and help!
 Top of the page
C:Amie Page Icon Posted 2023-01-24 11:01 AM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,931
Location:
United Kingdom
Status:
Right. I have updated CABMaker so that we know that the H/PC Pro 3.0 block also blocks HPC2000.

I have regenerated all of the HPC2000 CAB's so they won't now pop-up with a unsupported platform warning.

r.e. CEVB 1. Does anyone have a CE 2.00 device to hand? I'm out of AA's and can't find my 320's AC adapter. If so can you please install a PVB app and then dump me the entire registry using TRE. Thanks.
 Top of the page
1 2 3 4
Jump to forum:
Seconds to generate: 0.226 - Cached queries : 55 - Executed queries : 26