x
This website is using cookies. We use cookies to ensure that we give you the best experience on our website. More info. That's Fine
HPC:Factor Logo 
 
Latest Forum Activity

PVB Visual Basic Runtime MobilePro 900

1 2 3 4
torch Page Icon Posted 2023-01-24 3:49 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,540
Location:
United States 
Status:
Hi unfortunately my MobilePro 700 is dead so I won’t be able to test 2.0
 Top of the page
thenzero Page Icon Posted 2023-01-29 1:19 AM
#
Avatar image of thenzero
Subscribers
H/PC Elite

Posts:
744
Location:
United States
Status:
@C:Amie At torch's instruction I tested Airplane.pvb from the SCL on my MP780. After a hard reset, it does not run. With VBCE-2.Full.HPCPro.mips installed, it still does not run. With your CAmie.PVBTest.CEF and renaming the file to .vb, it runs.
 Top of the page
C:Amie Page Icon Posted 2023-01-29 5:44 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,929
Location:
United Kingdom
Status:
@thenzero, .pvb deffo won't run with the VBCE-2 runtime currently posted in the SCL as torch and I haven't started debugging VBCE 1.0's running via the 2.0 runtime yet. Faulty icons aside, I wanted to get a nice stable build of the 2.0 going first. That said, I did the first build for combining 1.0 and 2.0 together this morning and it's posted in the x86 thread for x86 only at the current time. If we can get that going then I will re-issue for all CPU architectures!

Good to know that CAmie.PVBTest.CEF did work though as that gives me hope that the mod's I've made to the x86 test might actually "just work"!

Cheers,
 Top of the page
thenzero Page Icon Posted 2023-01-29 7:13 PM
#
Avatar image of thenzero
Subscribers
H/PC Elite

Posts:
744
Location:
United States
Status:
Quote
C:Amie - 2023-01-29 5:44 PM

@thenzero, .pvb deffo won't run with the VBCE-2 runtime currently posted in the SCL as torch and I haven't started debugging VBCE 1.0's running via the 2.0 runtime yet. Faulty icons aside, I wanted to get a nice stable build of the 2.0 going first. That said, I did the first build for combining 1.0 and 2.0 together this morning and it's posted in the x86 thread for x86 only at the current time. If we can get that going then I will re-issue for all CPU architectures!

Good to know that CAmie.PVBTest.CEF did work though as that gives me hope that the mod's I've made to the x86 test might actually "just work"!

Cheers,


Ah OK. Let me know if I can be of any assistance testing on any of the devices I have as I'm happy to do so.
 Top of the page
C:Amie Page Icon Posted 2023-01-29 7:16 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,929
Location:
United Kingdom
Status:
Will do, depending on how the x86 goes, I'll build for others tomorrow.
 Top of the page
CE Geek Page Icon Posted 2023-01-30 12:57 AM
#
Avatar image of CE Geek
Global Moderator
H/PC Oracle

Posts:
12,653
Location:
Southern California
Status:
Quote
thenzero - 2023-01-28 5:19 PM

@C:Amie At torch's instruction I tested Airplane.pvb from the SCL on my MP780. After a hard reset, it does not run. With VBCE-2.Full.HPCPro.mips installed, it still does not run. With your CAmie.PVBTest.CEF and renaming the file to .vb, it runs.


I'd like to see that. We've never been able to get .pvb apps to run by changing the extension to .vb; there are multiple threads discussing this. Through all prior methods, doing this only froze up the system, requiring a soft reset.
 Top of the page
torch Page Icon Posted 2023-01-30 1:05 AM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,540
Location:
United States 
Status:
Thenzero sent me some screenshots of them working with pvb. C:Amie was working on a quasi-mixed runtime for VBCE1.0/2.0.
 Top of the page
CE Geek Page Icon Posted 2023-01-30 1:07 AM
#
Avatar image of CE Geek
Global Moderator
H/PC Oracle

Posts:
12,653
Location:
Southern California
Status:
I see that he is. But it doesn't sound like he's gotten there yet. If I'm reading correctly, it won't require changing any file extensions.
 Top of the page
torch Page Icon Posted 2023-01-30 1:10 AM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,540
Location:
United States 
Status:
Quote
C:Amie - 2023-01-23 5:28 AM

Okay. This is for CE 2.11+ on MIPS

1) On a clean device
2) Install the VBCE 2.0 Full if the device doesn't have it already installed (yes 2.0)
3) Install the attached
4) Let me know if .PVB is a registered file type in the registry
5) See if a .PVB will load at all

This is attempting to force the CEVB 1.0's .PVB loader to use CEVB 2.0's control DLL's, so I wouldn't hold your breath.

I wonder if he had inadvertently used this before C:Amie removed the attachment, or maybe a happy accident?



(thumbnail_IMG_6500.png)



Attachments
----------------
Attachments thumbnail_IMG_6500.png (81KB - 2 downloads)
 Top of the page
CE Geek Page Icon Posted 2023-01-30 1:13 AM
#
Avatar image of CE Geek
Global Moderator
H/PC Oracle

Posts:
12,653
Location:
Southern California
Status:
Nice.
 Top of the page
torch Page Icon Posted 2023-01-30 1:14 AM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,540
Location:
United States 
Status:
I found more Vicent Colura vb programs we don't have in the SCL, so I'll probably spam the SCL with new submissions soon!
 Top of the page
CE Geek Page Icon Posted 2023-01-30 1:21 AM
#
Avatar image of CE Geek
Global Moderator
H/PC Oracle

Posts:
12,653
Location:
Southern California
Status:
CEBeans is still up, and he has literally thousands of .vb programs up there now:

http://cebeans.com/
 Top of the page
torch Page Icon Posted 2023-01-30 5:45 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,540
Location:
United States 
Status:
Yes I’ve been working on testing them. I downloaded all of the A letter categories but only one so far worked on CE. I’ll add what tests as working!
 Top of the page
torch Page Icon Posted 2023-09-05 7:22 PM
#
Avatar image of torch
Subscribers
H/PC Guru

Posts:
5,540
Location:
United States 
Status:
@C:Amie
My memory is bad but is there any other testing we needed to do for PVB1.0 runtime on CE3.0 MIPS?
 Top of the page
C:Amie Page Icon Posted 2023-09-05 8:14 PM
#
Avatar image of C:Amie
Administrator
H/PC Oracle

Posts:
17,929
Location:
United Kingdom
Status:
@torch

It's been 9 months, you think I can remember?

I think that we concluded that it will work, but it has to be one or the other, possibly because of registry duplication. We could try running it from a non-Windows folder. I do not recall if we tried doing that.
 Top of the page
1 2 3 4
Jump to forum:
Seconds to generate: 0.234 - Cached queries : 72 - Executed queries : 10